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1. Courseware 

1.1. Courseware files 

Overview 

In this exercise we will unpack the courseware files and set the default RobotStudio folder. 

Extracting the Courseware folder 

Along with the RobotStudio Courseware you have received a RobotStudio Courseware.exe 

file.  

1. Double click the RobotStudio Courseware.exe file. 

2. In the Zip Self-Extractor dialog, browse to where you have your My Documents folder 

and select the RobotStudio folder. 

 
3. Click the Unzip/Extract button. 

Setting the RobotStudio User Project Folder 

4. On the File tab click Options. 

 
5. In the Options dialog select Files & Folders. 

6. In the User Project Folder click the browse […] button. 

7.  Browse to the Courseware folder that you just extracted and click the OK button. 
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8. Click OK. 

By setting the User Project Folder you have now created a shortcut that will appear in all 

open, import load and save dialogs. For example: 

 
Here we can see the Courseware button in the Open dialog 

Challenge 

If you have an internet connection you can visit the RobotStudio community. Go to 

http://www.abb.com/roboticssoftware . 

http://www.abb.com/roboticssoftware


Learning the basics 

 

6 

2. Learning the basics 

2.1. RobotStudio Overview 

2.1.1. Exploring RobotStudio 

Overview 

Before starting with the actual exercises, we will take a quick look at RobotStudio and 

commonly used functions. 

To open a demo station 

Now we will open a demo station to play with. Do not save any changes to the station during 

this exercise. 

1. On the Start menu select  

All Programs > ABB Industrial IT > Robotics IT > RobotStudio 5.60 > RobotStudio  

to start RobotStudio. 

2. In the File tab, click Open. 

 
3. Browse to the folder \Courseware\Stations and open the station Exploring. 

 

The main parts of RobotStudio window 

The picture on the next page shows the main parts of RobotStudio: 
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1 Quick Access Toolbar  

For quick access to commonly used commands and settings. To add an item to the 

toolbar, right click the item and select Add to quick access toolbar or click the 

arrow next to the toolbar and select Customize Commands.  

2 Tabs 

The tabs contain collections of commands and setting items for different aims 

according to the following table: 

File Opening, saving stations and options etc. 

Home Building up stations, creating systems, creating paths with 

graphical programming. 

Modeling Creating and grouping components, creating solids, curves and 

surfaces, measurements and CAD operations. This is also from 

where you create Smart Components and use the Mechanism 

Modeler. 

Simulation Setting up, configuring, controlling, monitoring and recording 

simulations.  

Controller For working with system parameters and configuration and setting 

up relationships to transfer programs, data etc. between controllers.  

(VC (Virtual Controller) or live controllers) 

1 

2 

3 

4 

5 

6 

7 

8 

9 
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Rapid Editor for writing new and/or debugging existing Rapid programs.  

Add-Ins PowerPacs and Add-Ins. 

Modify This is a contextual tab, which is only visible when an object is 

selected. It list specific commands for that object type. 

3 Layout and Paths&Targets browser 

The Layout browser displays the physical items of the station, such as robots and 

tools. When working with the objects, you either select them here or in the 

Graphics window. 

The Paths&Targets browser displays programming data such as controllers, tool 

data, work objects and targets.  

4 Output window and Simulation Watch 

The Output window displays messages from RobotStudio and the Virtual 

Controller. Some messages are active: by clicking on them you get more 

information. 

In Simulation Watch you will be able to monitor values of dynamic properties 

and IO signals in Smart Components. 

Note: Depending on main tab, different windows will show. 

5 Active Toolbar 

Shows active templates and parameters such as speed data and zone data. These 

are the default settings that will be used when creating Move instructions. 

6 RobotStudio Help menu 

Here you will find help on RobotStudio, Rapid, API etc. 

7 Documents Manager 

Allows you to easily search and browse for files to load into the station. It is also 

possible to add references to files and folders or embed files into the station. 

8 Graphics window 

The Graphics window displays the objects in the station. Here you select objects 

and parts of objects when building and programming stations. Icons for selection 

levels and snap modes can be found at the top of the Graphics window. Using 

correct selection level and snap mode settings is important for successful work in 

the Graphics window.  

9 Controller status bar 

A green light indicates that the controller is in AUTO mode, yellow that it is 

MANUAL mode, and red that it is not started. 

To explore selection levels and snap modes 

1. In the Graphics window click the Part Selection icon.  

 
The name of an icon appears as a ToolTip when holding the cursor over the icon. 
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2. In the Graphics window click the Snap Object icon.  

 
This is a multi-snap mode, snapping to the closest center, edge or corner. 

3. In the Graphics window click the fork lift. The entire fork lift is now highlighted red. 

You can also see the pick point as a white star that has snapped to the closest 

center/edge/corner. 

4. On the Home tab, in the Freehand group click the Move button. A cross with arrows in 

the X, Y and Z directions now appear on the truck. Drag the arrows to move the object. 

 
5. On the Home tab, in the Freehand group click the Jog Joint button and then select any 

joint on one of the robots. By pressing the left mouse button on one of the joints in the 

Graphics window you are able to jog it in any direction. 

 
6. Continue exploring the selection levels and snap modes by snapping to corners, edges 

and center points of parts, tools, entities and surfaces etc. 

7. Close the station without saving when you are done. 
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2.1.2. Navigating the Graphics window using the mouse 

Navigating the Graphics window using the mouse 

The table below shows how to navigate the Graphics window using the mouse: 

To Use the keyboard / 

mouse combination 

Description 

Select Items 

 

 

 

Just click the item to select.  

To select multiple items, press the SHIFT key 

while clicking the new items. 

Rotate the station 

 

CTRL + SHIFT + 

 

Press CTRL + SHIFT + the left mouse 

button while dragging the mouse to rotate 

the station. 

With a 3-button mouse you can use the 

left and middle buttons, instead of the 

keyboard combination. 

Pan the station 

 

CTRL + 

 

Press CTRL + the left mouse button while 

dragging the mouse to pan the station. 

Zoom the station 

 

CTRL + 

 

Press CTRL + the right mouse button while 

dragging the mouse to the left to zoom out. 

Dragging to the right zooms in. 

With a 3-button mouse you can also use 

the middle button, instead of the keyboard 

combination. 

Zoom using 

window 

 

SHIFT + 

 

Press SHIFT + the right mouse button 

while dragging the mouse across the area 

to zoom into. 

Select using 

window 

 

SHIFT +  

 

Press SHIFT + the left mouse button while 

dragging the mouse across the area to 

select all items that match the current 

selection level. 
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2.1.3. Managing document folders 

Create a gallery for frequently used documents 

It is possible for the users to create a document gallery in order to easily access their 

frequently used documents. The galleries can be created using the Documents window, and 

are also placed in Import Library or Import Geometry menus in the Home tab. 

 

1. On the Documents window, press on Locations in order to add and locate your galleries. 

 
2. When the Document Locations dialogue box appears, click on Add Location > File 

System, as depicted in the picture below. By doing so, the File System dialogue box will 

pop up.  

 
3. Now we want to create a gallery for the library objects located in the courseware folder. 

On the File System dialogue box, name the new location as Courseware. Then set the 

path to the Library folder located in the Courseware folder, and select *.rslib as a Filter 

from the dropdown menu. Set up the rest of parameters as shown in the following picture 

and press OK. 
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4. Now you can see the Courseware gallery added to the Document Locations list.  

 
5. Press OK in order to complete the task and add the gallery to the Import Library menu. 

The result will be the same as the below picture. 

 
 

You can now create a gallery for Import Geometries following the above instruction. See the 

picture below for the settings in the File System dialogue box. 

 

Searching a specific documents 

Using the Search function in Documents window, you can search for a document by its 

name. The result will appear on the Documents window. Then you can double-click on the 

found item(s) in order to import it to the station. You can also use the Browse function in 
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order to browse to all available locations created in Document Locations. These functions 

provide an easy, quick access to your documents. 

      

2.2. Creating a basic station 

Goal of the chapter 

In these exercises we will learn how to build a basic station containing a robot, a tool, a fixture 

and a work piece as shown in the picture. Later in the course we will program the robot to 

operate on the work piece. 

 

2.2.1. Creating a new station 

Overview 

A new station can be created in three ways: 

 With no system - starting from scratch with an empty station and then add a new or 

existing system to it. 

 With a template system - this is the simplest way to create a new station with a robot and a 

link to a rudimentary system template. 

 With an existing system - this creates a new station containing one or more robots in 

accordance with an existing, built system. 
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In this exercise we will use the second alternative. 

Creating the new station 

1. In the File tab, click New and then select a new Station with Robot Controller. 

2. By default, template systems are listed in the right pane of the window. Select IRB1600 

6kg 1.2m and then click create. 

 
3. In the File tab select Save As.  

4. Browse to the folder \Courseware\Stations and save the station as MyStation_1. 

Learn more 

Click the Help button  in the top right corner of RobotStudio. 

See the help section for information about 

Workflow for building a new station Creating stations and systems. 

2.2.2. Adding a tool 

Overview 

We will now import and attach a tool to the robot. This is done in two steps: first we import the 

tool to the station and then we attach it to the robot. 

The tool that we will import is a library component, which means that it is a RobotStudio object 

that has been saved as a separate file. The library import creates a link from the station to the 

library file on the hard drive. Therefore, several stations can share the same library component. 

On the Home tab you can find the Import library button, it has two sections: 

1. The upper button opens up a dialog where you can browse for libraries. 
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2. The lower part that opens up default RobotStudio libraries and personal galleries. 

 

Importing the tool 

1. Open the station from the last exercise (Mystation_1), unless it is already open. 

2. In the Home tab click the Import Library button. Since you have already created the 

Courseware gallery to this menu, you can now easily select the needed library 

component from this gallery. Click the Courseware gallery and select Pen. 

 
 

The tool will be imported to the station and placed at the origin of the world coordinate 

system, thus hidden inside the robot. However, in the Layout browser you can see that 

the tool has been imported. 

Attaching the tool 

1. Inside the Layout browser, drag the tool Pen and drop it on the robot IRB1600. 
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2. Answer the question “Do you want to update the position of Pen” with Yes.  

 
The tool is moved to the wrist of the robot. 

3. Save the station as MyStation_2. 

2.2.3. Importing the controller cabinet 

Overview 

We will now import a model of the controller cabinets to the station. The controller model is 

for visual representation only, the Virtual Controller runs regardless if there is a cabinet or 

not. 

Importing the controller cabinet 

1. Open the station from the last exercise (Mystation_2), unless it is already open. 

2. On the Home tab click the Import Library button (lower section).  

3. In the Equipment folder, select the IRC5_Control-Module library. 

 
The cabinet will be imported to the station and placed at the origin of the world 

coordinate system. 

4. Save the station as MyStation_3. 

2.2.4. Moving the controller cabinet 

Overview 

We will now move the controller to a more suitable position in the station. If not the exact 

position is important, Freehand move is an easy way to modify the position of objects. 

RobotStudio has several functions for moving objects, each suitable for different situations. In 

this exercise the exact position is not important as long as it is placed out of reach from the 

robot so we will use the Freehand move. 
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Moving the controller cabinet part 

1. Open the station from the last exercise (Mystation_3), unless it is already open. 

2. In the Layout browser select IRC5_Control-Module or use selection level Part to make 

the selection directly in the graphics window. 

3. On the Home tab, in the Freehand group click the Move  button. 

 
4. Click and hold on the green arrow in the Freehand move cross, then drag the controller 

one floor square (about 1 meter) to the right of the robot (negative Y direction). Then 

click and hold on the red arrow and drag it one square backwards (negative X direction). 

 
5. Save the station as MyStation_4. 

2.2.5. Importing CAD files 

Overview 

You add work pieces and custom equipment, like fixtures or conveyors, by importing the 

CAD models of the objects. In this exercise we will import a table and box. 

Importing the CAD files 

1. Open the station from the last exercise (Mystation_4), unless it is already open. 

2. On the Home tab click Import Geometry. 

3. In the Open dialog browse to \Courseware\Geometry then hold down the [CTRL] key 

and select the objects Box.sat and Table.sat.  
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4. Click the Open button. 

 
5. Save the station as MyStation_5. 

Learn more 

Click the Help button  in the top right corner of RobotStudio. 

See the help section for information about 

Libraries, geometries and CAD files Supported CAD formats and import options 

Troubleshooting and optimizing 

geometries 

How to solve geometry problems like slow 

updates and invisible parts. 

  

Challenge 

The detail level of a model can be changed to increase the performance for large models. 

Open the Options dialog and go to Graphics>Performance.  

To increase performance for large models, set the detail level to Coarse. This only affects the 

visual representation of the object, not the accuracy when generating curves and targets. 

To improve visual display and make it easier to select points in objects with many details, set 

the detail level to Fine. 

When you are finished, change back to the default value, Automatic. RobotStudio will then 

determine which level to use based on the zoom factor in the station. This increases the file 

size of the station. 

2.2.6. Positioning the table 

Overview 

The table will be moved 600 mm from the Base Frame of the robot in X direction, 100 mm in 

Y direction, and finally with a -30º rotation around Z. We will use the Set Position command 

for this movement. 

Positioning the table 

1. Open the station from the last exercise (Mystation_5), unless it is already open. 

2. In the Layout browser right click the Table and select Set Position. 
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3. In the Set position dialog, in the Reference list select the World coordinate system. 

4. In the Position fields enter these values 600, 100, 0. 

5. In the Orientation fields enter these values 0, 0, –30. 

 
6. Click Apply. 

 
7. Save the station as MyStation_6. 

2.2.7. Placing the box 

Overview 

We will now place the box at one of the corners of the table. For placing an object relative 

another without knowing the exact coordinates, the Place commands are well suited. Now we 

will use the Place by two points command since we need to both move the box and change its 

orientation around one axis. 

 

TIP! 

When selecting a corner of an object, make sure to click inside the surface of the object, this 

to make sure the pick point will snap correctly. 

Placing the box on the table 

1. Open the station from the last exercise (Mystation_6), unless it is already open. 

2. In the Graphics window select the Part Select level and the Snap End mode. 
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3. Rotate and zoom the station so you get a view similar to the one in the picture below. It 

is easier if you have a clear view of the box and the corners of the table. 

 
4. In the Layout browser right click the box part, point to Place select Two Points. 

5. When the text insertion point is positioned in any of the Primary point - From boxes, 

click the corner of the box marked with 1 in the picture.  

6. When the text insertion point is positioned in any of the Primary point - To boxes, click 

the corner of the table marked with 2.  

7. When the text insertion point is positioned in any of the Point on X-Axis -From boxes, 

click the corner of the box marked with 3.  

8. When the text insertion point is positioned in any of the Point on X-Axis -To boxes, 

click the corner of the table marked with 4.  
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9. Click Apply.  

  
The primary point on the box is now moved to the primary point on the table and the 

points on the X-Axis set the orientation of the box. 

10. Save the station as Mystation_7. 

2.3. Programming the basic station 

2.3.1. Jogging the robot 

Overview 

Before programming the station, we will practice jogging the robot. Jogging the robot can be 

done in several ways but here will use the freehand functionality. Note that both Mechanism 

Joint Jog and Mechanism Linear Jog are available also from the Modify tab which is 

enabled when the robot is selected in the Layout browser.  

 
 

Jogging the robot joint by joint 

1. Open the station from the last exercise (Mystation_7), unless it is already open. 

2. On the Home tab, in the Freehand group click Jog Joint. 
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3. In the Graphics window select one of the joints and move it by dragging the mouse. 

 

Jogging the robot linearly 

1. On the Home tab, in the Freehand group click Jog Linear. 

 
2. In the Graphics window select the robot by clicking on it. 

A cross with red, green and blue arrows is now displayed at the Tool Center Point (TCP). 

 
3. Click and drag the arrows to jog the robot. Use the red arrow for X direction, green for Y 

and blue for Z. 

Reorienting the tool of the robot 

1. On the Home tab, in the dropdown list of the Freehand group select Active Tool. 

2. Click the button for Jog Reorient. 

 
3. In the Graphics window select any part of the robot. 

Circular arrows are now displayed around the TCP.  
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4. Drag the arrows to reorient the tool around its current TCP position. 

 

Jumping back to the neutral position 

After finishing the jogging practice, jump back to the original neutral position. 

1. In the Layout browser, open the context menu by right clicking the robot and then select 

Jump Home. 

2.3.2. Creating a Workobject 

Overview 

The first thing we will do when programming the station is to create a workobject coordinate 

system. Workobjects are special coordinate systems in which the programmed positions are 

stored. Correctly used, workobjects facilitate calibration and modifications of the cell layout: 

if repositioning the work piece or the robot itself, you just reposition the workobject 

correspondingly, and the program is up-to-date again.  

Programming a robot without having specific workobjects is possible, but not recommended. 

A default workobject, Wobj0, which always is fixed at the origin of the controller’s world 

coordinate system, will be used in that case. 

 
A workobject consist of two frames. The User Frame (User coordinate system) is referenced 

from the World Coordinate System and the Object Frame (Object coordinate system) is 
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referenced from the User Frame. See picture above where the position of two different parts 

located in the same fixture are described.  

Creating the workobject 

1. Open the station from the last exercise (Mystation_7), unless it is already open. 

2. In the Graphics window select the Part Select selection level and the Snap Object snap 

mode. 

 
3. Rotate and zoom the station till you get a clear view of the top of the box. 

 
4. On the Home tab click on Other and select Create Workobject from the drop-down 

menu.  

5. In the Create Workobject dialog, in the Name box enter Wobj_Box. 

 
6. In the User Frame group click the Frame by points box and then click the drop-down 

arrow.  

7. In the Frame by points dialog select Three-point as method for defining the frame. 

8. Set the insertion point in one of the First point on X axis boxes and then click the corner 

of the box marked as 1 in the picture above.  

The coordinates of the selected point are now inserted in the boxes and the insertion 

point moved to the Second point on X axis boxes. 
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9. Continue clicking in corners 2 and 3 in Second point on X axis and Point on Y axis, 

respectively. 

 
10. Click Accept.  

The Create frame by points dialog will close.  

11. In the Create Workobject dialog click Create. 

A workobject, displayed as a coordinate system, is now created on the box. You can also 

see the workobject in the Paths&Targets browser. 

 
 

12. Save the station as MyStation_8. 

Learn more 

Click the Help button  in the top right corner of RobotStudio. 

See the help section for information about 

About coordinate systems Workobjects and other coordinate systems useful 

when programming a robot. 

 

2.3.3. Programming motion 

Overview 

Paths are RobotStudio elements that contain the instructions for the robot. The order in which 

the instructions are stored in the path is the order in which they will be executed. 

We will create a path where the robot moves along the sides of the small box on top of the big 

one. This is done by 'graphical programming', i.e. by clicking in the graphics. 

 

To get a working robot path, we need to go through a couple of different steps. First we will 

use the corner points of our graphical part to create targets. After this we will adjust the 
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orientation of the targets. Finally we will add these targets to a path and set appropriate axes 

configurations for each instruction. 

Creating the targets 

1. Open the station from the last exercise (Mystation_8), unless it is already open. 

2. In the Graphics window select Part Selection level and Snap End. 

 
3. Zoom and rotate the station so that you get a clear view of the tool and the small box. 

 
4. On the Home tab click the Target drop-down and select Create Target. 

5. In the Create Target dialog, make sure the pointer is set to the first Position box. 

 
6. In the Graphics windows click the corners on the top surface in the same order as in the 

picture above. 

 
The red stars show positions where targets will be created. 

7. In the Create Target dialog click the Create button.  

Now 4 targets are created with default orientation (0,0,0). 

Adjusting the target orientation 

To get a good view on the current orientation of the targets we will use the function 

View Tool at Target which will give us a preview on how the tool will be oriented 

around the targets.  

 

1. In the Paths&Targets browser select the first target (Target_10) and click the Modify 

tab.  

2. In the View Tool at target drop-down, select Pen. 
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As the orientation of our targets are zero and our TCP has Z pointing out from the tool, 

the preview of the tool will be hidden in the box. To be able to see this preview we need 

to make the box invisible 

 

3. In Layout browser un-check Visible in the context menu of the box. 

 
Next step is to set a suitable configuration on the first target and then re-use this 

orientation for the rest of our targets. If the exact orientation is known, it is easiest to 

manually type these values into the Set Position dialog. In this case when we have no 

exact values we will manually adjust the orientation of the first target. 

4. In the Freehand group select reference Local in drop-down list.  Then select Target_10 in 

Paths&Targets browser and then enable the Rotate button.  

 

As a help to see if a target is reachable we will now enable the function View Robot at 

Target. 

5. In the context menu of Target_10, select View Robot at Target. Now the robot will 

jump to the target as soon as it is possible to reach. 

6. Rotate the target approximately +180 degrees around the Y axis by click&drag on the 

green arrow. 

7. Rotate the target approximately +15 degrees around the Z axis by click&drag on the blue 

arrow. 

 
Tip! 

If you press the [f]-key while rotating, the rotation will execute in smaller steps. 

 

8. In the context menu of Target_10, click Modify Target>Set Position. 
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9. Select World as reference and make the final adjustments to round off the angles as in 

pictures below. Press Apply. 

 
10.  In the context menu of Target_10, select Copy Orientation. 

11.  Multi-select the three remaining targets and click Apply Orientation from the context 

menu. Now all targets will have the same orientation. 

 
12.  Make the box visible again by checking Visible from the context menu. 

13.  Step through the targets and make sure they are all possible to reach. As View Robot at   

Target is activated the robot will automatically jump to the targets if possible.  

14.  Disable View Tool at Target, View Robot at Target. 

15.  Save the station as MyStation_9. 

Adding the targets to a path 

1. Open the station from the last exercise (Mystation_9), unless it is already open. 

2. On the Home tab click Empty Path from the Path drop-down menu. 

  
An empty path, Path_10, is now created and displayed in the Paths&Targets browser. 

3. Right click the path, select Rename and change the name to Path_Box. 

 

On the Status Bar down at the bottom of the interface you can see the active instruction 

template. These are the default settings that will be used when creating the Move 

instructions. 
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4. Change the parameters according to the picture below. 

 
5. In the Paths&Targets browser multi-select the four targets. 

 
6. On the Modify tab click the Add to Path button and select Path_Box and First. 

 
7. In the Paths&Targets browser select Target_10. 

8. On the Modify tab click the Add to Path button and select Path_Box and Last. Now the 

loop is closed. 

 
Tip! 

You can also use drag&drop to create the instructions. 

 

9. Select the path, and in the Modify tab select Rename Targets. Write pBox_ as target 

prefix and press Apply. This function also available from the context menu of the path. 

   
10.  Save the station as MyStation_10. 
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Setting axes configuration 

Before we can setup and run a simulation we need to define what axes configurations the 

robot should have for each target. This can be done manually by stepping through each 

instruction and clicking Configurations from the context menu. In this way you will get 

a list of all available configurations. In cases where we have many instructions a more 

efficient way is to use Auto Configuration. In this way we will only set the start 

configuration and then RobotStudio will calculate the configuration for the rest of the 

instructions in order to get as smooth movements of the robot axes as possible. 

 

1. Open the station from the last exercise (Mystation_10), unless it is already open. 

2. Select Path_Box and click Auto Configuration from the Modify tab. 

 
3. Select the first configuration in the list and press Apply. The robot will now run through 

all instructions and get valid configurations on all remaining. 

 
4. Save the station as MyStation_11. 

 

Tip! 

Auto Configuration is also available from the path context menu. 

Learn more 

Click the Help button  in the top right corner of RobotStudio. 

See the help section for information about 

About targets and paths Targets, paths and move instructions. 

Robot axis configurations Axes configurations 

2.3.4. Running the Simulation 

Overview 

Now we have completed all steps required to proceed creating a RAPID program. The 

strength with the virtual controller is that we use the same software as the real robot 

controller. This means that we are able to run a simulation where we get very close to the 
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same behavior as on a real robot controller. The robot program will be stored on the system 

running on the virtual controller, just as the program for a real robot is stored on its system.  

Synchronize to the Virtual Controller 

1. Open the station from the last exercise (Mystation_11), unless it is already open. 

2. On the Home tab, click the Synchronize button.  

 
3. In the Synchronize to VC dialog make sure all data are selected and then click OK.  

 
All program data is now transferred from the RobotStudio station to the virtual 

controller. 

4. To get a view of the result, expand the tree structure in the Rapid tab, and double click 

Module1 as shown below. 

 

Setup the Simulation 

To be able to start a simulation we need to define where the robot should start the 

execution. This can be done by adding a main sequence directly in the Rapid Editor or 

we can use the Simulation Setup dialog where we get this done automatically. 

 

1. On the Simulation tab click the Simulation Setup button. 

  
2. Select Path_Box and click the arrow pointing to the left in order to add it to main 

procedure.  
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3. Click the OK button. 

4. Now go back to the Rapid editor to see the resulting main sequence. 

 
5. In the Simulation tab click the Play button. The robot will now execute the RAPID 

program. 

2.3.5. Adding a start and home position 

Overview 

To be sure that the robot can execute this linear path we will add a new target which we will 

use as an approach/depart target. As the path, so far, only consists of linear instructions 

problems will appear in situations where the actual position of the robot makes a linear 

movement to the first instruction impossible.  

Adding an approach/depart target 

 

1. In the Paths&Targets browser select copy from the pBox_10 context menu. Then click 

Paste from the Wobj_Box context menu. 

2. Rename the target to Appr_Box. 

3. Select Appr_Box and click Set Position from the Modify tab.  

 
4. Set the reference to Local and move the target -150mm in the Z direction. Press Apply. 
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5. In the toolbar for active templates, change to MoveJ and set the parameters as below. 

 
6. Select the target Appr_Box and then add it to the top of the path. 

 
7. Change back to MoveL as active template. 

 
8. Repeat step 6 but now add the instruction last in the path.  

  
Note that the yellow triangle warning appears on the new instructions. This is because no 

axes configuration is set yet. 

9. Select Path_Box and click Auto Configuration from the Modify tab. 

 
10.  Select the first configuration in the list and click Apply. The selected configuration will 

now be set to the first target and calculated for the others. 
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Now we will also add a Home position that we will place in a separate path. 

11.  From Home tab, create a new empty path and rename it to Home.  

  
12.  In Home tab, select Jump Home from the context menu of the robot. The robot will 

now reset the axes to default values. 

13.  From the Modify tab, select Mechanism Joint Jog. 

 
14.  Jog the robot according to the screenshot below. 

 
Tip! 

Click the separate boxes for each axis and press space on your keyboard. Now you will 

be able to write exact values. 

15.  Change active work object to wobj0 from the Settings group in Home tab. 

16.  In the toolbar for active templates, change to MoveJ and set the parameters as below. 

 
17.  In Path Programming group of Home tab, click Teach Instruction. 

 
A new target will now be created in wobj0 and a MoveJ instruction will be added to the 

new Path. Press yes on the message that follows. 
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18.  Rename the new target to HomePos. 

 
19.  To transfer the new instructions to the virtual controller, click Synchronize to VC from 

the RAPID tab. 

 
20.  Make sure everything is selected and then click OK. 

21.  Save the station as MyStation_12. 

 

Tip! 

Note that synchronization can be done in several ways. The Synchronize button appears 

in both the Home and Rapid tabs. Alternatively right clicking on either the system or a 

particular path in the Paths&Targets Browser on the Home gives you this same option. 
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2.3.6. Using the Rapid Editor for basic adjustments 

Overview 

In this section we will look into how to use the Rapid Editor for basic adjustments of our 

program. We will also step through each instruction one by one. Later in the course we will 

learn how to use the more advanced features for debugging and editing. 

Rapid Editor 

1. Open the station from the last exercise (Mystation_12), unless it is already open. 

2. In the Rapid tab, expand the tree structure and double click Module1 as shown below. 

 
3. Click in the main procedure and add a call to the Home. 

 

 
Note the IntelliSense as you start to type. The return key will add the highlighted 

instruction/procedure.  

 

4. Change the speed to v1000 in the HomePos instruction. 

 
5. Click Apply changes. 
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6. Confirm the change by clicking YES. 

 
 

7. To be able to see both our graphical view and the program, click New Vertical Tab 

Group by right clicking the editor tab.  

  
 

8. In the Virtual Controller group of the Controller tab, open the Control Panel and 

change to AUTO mode and push the Motors Button. 

 

   
 

Tip! 

Click the  button up in the right corner to switch style of the Control Panel. 

 

9. Back in the Rapid tab Set the program pointer to the main routine 
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10.  Use the Step in (F11) function  to step through the program. 

 

As we now have done changes to the program directly in the virtual controller, we need 

to synchronize the changes back to the station.  

11.  While still in the Rapid tab, click the lower half of the Synchronize button to reveal the 

Synchronize to Station feature.  Synchronize to the station. 

 
12.  In the dialog, check the top node so that everything get selected and press OK. 

 
13.  In Simulation tab, click the Play button. Note that the robot now first go to the Home 

position we added to the main procedure from the Rapid Editor. 

 
14.  Save the station as MyStation_13 

15.  Save the station as a Pack&Go from the Share section of the File tab. A Pack&Go file 

will include all data required to restore the station and system so this is the recommended 

way of saving a project when finished or when moving to another PC. 
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2.3.7. Simulation settings 

Overview 

In this section we will look into the RobotStudio options for simulation settings. The 

Simulation speed setting allow you to set the simulations speed relative the real time. This can 

be useful when having longer simulations where you want to save time running through the 

simulations. 

RobotStudio Options 

1. Open the station from the last exercise (Mystation_13), unless it is already open. 

2. From the File tab, click Options. 

 
3. Go to the Simulation section and click Accuracy and check As fast as possible. Then 

click OK. 

 
4. Press Play from the Simulation tab to run the simulation again. Now note that it will run 

through the simulation in a much shorter time but the resulting process time will be the 

same.  

5. Go back to Options and uncheck As fast as possible again. 

Learn more 

Click the Help button  in the top right corner of RobotStudio. 

See the help section for information about 

Options RobotStudio Options 

2.3.8. Saving the robot program 

Saving the robot program 

1. In the Rapid browser, select Save program As from T_ROB1 context menu. 
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2. In the folder \Courseware\RAPID Programs save the program as BoxProgram_1. 

 

Summary 

Now we have created a robot program that can be loaded to a real robot. The saved modules 

can be viewed or edited using the Rapid editor or any text editor. 

Basically, our program exists in three independent versions now: 

 In RobotStudio, where the positions and motion properties are saved in the path. 

 In the virtual controller, where it is stored in the controller’s program memory just as on 

a real controller. 

 As files on the hard drive, which we saved from the virtual controller through 

RobotStudio. 

2.4. Local Origin 

Overview 

In the next three exercises we will work with the same station but with another tool and work 

piece loaded. The tool will be created from a CAD file using the tool wizard. We will also 

work with a new work piece which will require some changes to the station, concerning 

frames. We will start with looking into Local origin. 

Each CAD file has its own local coordinate system called Local origin. In this exercise we 

will explain why this coordinate system has big impact on many operations in Robot Studio. 

We will import a CAD file for a tool that was saved in a way that we need to modify its 

coordinate system to be able to use it in our simulations. 

Tool wizard 

1. From the Share section in the File tab select Unpack & Work and unpack the file 

TaskFrame.rspag from Courseware\Stations. 

2. In the Select the directory where the files will be unpacked field click the Browse 

button.  
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3. In the dialog browse to \MyDocuments\RobotStudio\Courseware\Stations\ click New 

Folder and name it myBasicStation. 

 
4. Click the Select Folder button. 

 

 
5. Click the Next button. 

6. Check the controller system dialog and click the Next button. 

7. Click the Finish button. 

8. When finished, click the Close button. 

9. Import the geometry SpintecTool.sat from the Courseware folder. 

 
A geometry representing the tool is now imported to the station and placed with its local 

origin in the zero point of the world coordinate system. As the local origin on this 

specific part is not placed in the attach point of the tool you will see the offset between 

the coordinate system and actual CAD part. 
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Attach to Robot 

To show why this can be a problem we will attach the tool geometry to the robot. 

1. In the Layout browser right click the SpintecTool and on the context menu point to 

Attach to and select the robot. 

 

Tip! 

Drag&drop is often easier when using the Attach command. 

 

2. In the Update the position dialog click Yes. 

 
Due to the definition of the local coordinate system of the part, you get an offset of the 

tool. This is what we now have to fix. 

3. In the context menu of the SpintecTool, select Detach. 

Setting the Local Origin 

1. Make the robot invisible by un-checking Visible from the context menu. 

2. In graphics, zoom so you get a good view of the tool. 

 
 

3. Select Selection level Surface and Snap mode Center. 
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4. In the Layout browser right click the SpintecTool and select Place. In this case we will 

place the object by one point.  

5. Make sure the pointer is in one of the Position boxes and then click the surface as in 

picture above. 

 
Tip! 

To avoid clicking on the floor, go into RS Options and make the floor invisible. 

 
 

6. Click Apply. This will move the SpintecTool to RobotStudio world zero. 

7. In the Layout browser right click the SpintecTool and select Rotate. In this case we will 

rotate the object about the world coordinate system by 90 degrees. Click Apply. 

 
 

At this point if we were to attach the tool to the robot it would still not go to the correct 

position as the attachment point reference is still the local coordinate system of the part.  
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In the next steps we will adjust the local coordinate system to match the position of the 

model. 

 

8. In the Layout browser right click the SpintecTool and select Set Local Origin. You will 

notice in the dialog box the following values.  

 
  

 We will now correct these values to coincide with the corrected CAD model by changing 

all values to zeros. Click Apply. 

 

 
 

The coordinate system is now moved to coincide with the actual position in the station 

which also happens to be the attachment point of our tool geometry.  

 

 
9. Attach the tool geometry to the robot to see the difference. Now it should attach 

correctly. 

10.  Detach it again. 

 

Exporting the Geometry 

Now we will export the geometry with a new name for later use.  
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11.  In the Export group of the Modify tab which is visible after selecting SpintecTool in 

the browser, click Export Geometry. (Also available from context menu.) 

 
12.  In the Save As dialog change the name to mySpintecTool. 

13.  Click the Save button. 

 
14.  Make the robot visible again. 

Learn more 

Click the Help button  in the top right corner of RobotStudio. 

See the help section for information about 

Introduction 

>Terms and Concepts 

>Libraries, geometries and CAD files 

Definitions and overview of the geometry and 

library system in RobotStudio. 

 

2.5. Creating a tool 

Overview 

In this exercise we will create a tool from the CAD file saved in previous exercise and save it 

as a library component. To do this we will import a geometry representing the tool. From this 

geometry we specify a Tool Center Point (TCP) and some other parameters. When the tool is 

finished we will save it as a library component and attach it to the robot. 

Preparing the geometry 

Note! After creating a tool the geometry will no longer be editable and cannot be used for 

creating tools again. This means that it is a good practice to make a copy or export the 

geometry to file before creating the tool, if you do not already have one. 

1. Unpack the Pack&Go file TaskFrame.rspag from Courseware\Stations unless the 

station is still open. 

2. Import the geometry mySpintecTool.sat from the Courseware folder unless it is already 

imported. 
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A geometry for the tool is now imported to the station and placed at the origin of the 

world coordinate system. Note that this is the geometry we fixed in the local origin 

exercise. If necessary there is a correct copy in the Solutions folder. 

3. In the Layout browser right click the robot and uncheck Visible.  

 

 
Click in the Graphics to remove the red marking and the robot will now be invisible and 

you can see the tool on the floor. In the Layout browser the node for the robot is marked 

with a magnifying glass , indicating that it is not visible in the Graphics window 

Creating a reference frame 

To simplify the later TCP definition we will start by creating a reference frame. 

 

1. Zoom and rotate the station so that you get a clear view of the tip of the tool. It is 

important that you see the circular front of the tip clearly. 

 
2. On the Home tab click the Frame drop-down and select Create Frame. 

 
3. In the Graphics window select Surface Selection level and Snap Center. 

 
4. In the dialog click in the Frame Position field and then in the Graphics window click on 

the tip surface. 
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The snap goes to the center of the surface as our selection level and snap mode. 

5. Click the Create button. 

 
As we did not define an orientation it mimics the world coordinate system. Now we will 

use the graphics to get the angle of the tool. 

6. In the Layout browser right click Frame1 and select Set Normal to Surface. 

 
7. In the Set Normal to Surface dialog click the top field and then in the Graphics window 

click the tip surface. 

8. Click the Apply button. 

 
Since the default definition of the approach direction is positive Z it points out of the 

surface. 

Creating the new tool 

Now that we have both graphics and frame we will use these to create a tool. 
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1. In the Mechanism group of the Modeling tab click the Create Tool button to start the 

wizard. 

 
2. In the Create Tool wizard in the Tool Name field enter mySpintecTool. 

3. To select a part click the Use Existing button and in the drop-down list select the 

mySpintecTool part. 

4. Type in 3kg as mass. 

5. In the Graphics window select Part Selection level and Snap Gravity. 

 
6. In the Create Tool dialog click in the Center of Gravity field and then in the Graphics 

window click the tool graphics. 

 
Note that snap gravity assumes that the object is of the same density when calculating 

the center of gravity. You can also type in moment of Inertia but there is no RobotStudio 

functionality for this so you have to get the data externally. 

7. Click the Next button. 

8. In the TCP Name field enter tSpintec. 

This is the name of the tooldata that will be used in RAPID 

9. In the Values from Target/Frame click the field and then on Frame_1. 

10.  Click the large arrow [->] button to add the TCP. 
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11.  Click the Done button. 

 
In the Layout window we can see that the geometry part has been replaced by the tool 

mechanism. But that the frame remains. 

12.  In the Layout browser right click the Frame_1 frame and select Delete. 

Saving the tool as a library component 

Saving the tool as a library component makes it available for use in other stations as well. It 

also means that if you update the library then all stations using the library will be updated 

the next time you open them. 

1. In the Layout browser right click the tool mySpintecTool and select Save as Library 

from the Modify tab. 

 
2. In the Save As dialog enter \Courseware\Libraries\mySpintecTool.  

 
Note the small floppy disk that shows that the tool now is a library file. 

Attaching the tool to a robot 

1. Right click in the Graphics window and select View All.  

The station now zooms out so that all objects are visible. 

2. In the Layout browser right click the robot and make it visible again.  

3. Attach the tool to the robot. 
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4. In the Update the position dialog click Yes. 

 
The tool is attached to the flange of the robot.  

 
5. Save the station as \Courseware\Stations\MyStation_NewTool.rsstn.  
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2.6. Task Frame 

Overview 

Now we have created a new tool that we will use when executing the path on the new work 

piece. Working in RobotStudio requires understanding about several different coordinate 

systems. In this chapter we will learn how to work with the Task Frame. As these concepts 

will follow through the whole training materiel, it is very important to understand the 

differences between these, as mentioned below. 
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Moving the TaskFrame 

1. Open the station from the last exercise (MyStation_NewTool.rsstn), unless it is already 

open. 

 
As we can easily see in this station, we will not be able to execute the path on top of the 

work piece without moving the robot. This can be done on two ways; either by moving 

the BaseFrame of the robot or moving the TaskFrame of our controller. To avoid 

BaseFrame values in the controller we will change the TaskFrame which is the 

recommended way. The recommendation is to only modify the BaseFrame values when 

required, such as in MultiMove Systems or working with external axes. Later in the 

course we will see situation where this is required. 

2. Import the geometry Stand.sat from the \Courseware\Geometry folder.  

3. In the Controller tab select the system and click on the Task Frames button. 

 
4. In the Position XYZ fields enter 0, 0, 600 with world as reference. 

 
5. Click on the Apply button. 

6. As you do not want to have an offset to the BaseFrame, answer Yes on the question 

“Do you also want to move the base frame(s)?” 

 
7. As a workobject including targets is pre-created in this station which we do not want to 

move the same distance, answer Yes on the question “Do you want to keep the 

positioning of all stationary RAPID objects?” 
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The robot is now moved up on the robot stand, with all target locations kept.  

 

Making thefinal adjustments 

Now we will make sure the robot can reach the targets and run auto configuration to set 

suitable axes configurations 

 

1. Activate View Robot at target and step through all the targets in the workobject, 

obWorkPiece. 

 
2. As all targets seems to be possible to reach, de-activate View Robot at target again. 

3. Set MoveL as active template from the toolbar with parameters as below. 

 
4. Multi-select all targets and add them to a new path by clicking Add to new path from the 

Modify tab. 

 
5. Add the Approach target also as first instruction. This time, set MoveJ as active 

template. 
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6. Run Auto Configuration to set the axes configurations. Either from the context menu of 

the path or the Modify tab. 

 
7.  As configuration for the first target, select (0,0,-1,0). Press Apply. Now the 

configurations for the rest of the targets are calculated. 

8. Now use your knowledge from earlier parts of this course, to setup and run a simulation. 

You need to first synchronize the path to the VC and then setup the simulation. 

9. Save the station as MyStation_NewPath.rsstn. 

 

Learn more 

Click the Help button  in the top right corner of RobotStudio. 

See the help section for information about 

Coordinate Systems The different coordinate system used 
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