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What the Tutorial /s and what it is not

@ An introduction to LyX
@ NOT a tutorial on how to write a good thesis.

o Please consult your SV



Thesis?

What is a Thesis?

It is a documented evidence of defined scope and length that a
candidate is

Understand relevant theoretical issues

Technically competent
Has critical-thinking ability

Able to conduct scholarly research



Thesis?

Different Names of Thesis

@ According to UTM convention

e UG FYP - report

e Master by taughtcourse project - project report

o Master by taughtcourse and research (mixed-mode) -
dissertation

o Master by research and PhD - thesis

@ What make them different is the breadth and depth



Thesis?

FYP vs. Master Project Report

Both as partial fulfillment for the degree
@ For UG, as a documented proof that

@ You are ready to be an EE engineer
e You can propose a solution to a practical problem by
integrating knowledge from different courses

@ For Master by TC, as a documented proof that

e You are ready to be an expert EE engineer

e You can propose a solution to a practical problem by
integrating state-of-the-art techniques and methodologies

e You ave comprehensive knowledge on you area of research
(Master project report)



Thesis?

Research Master's vs. PhD

As the full fulfillment for the degree

@ The philosophical nature of a thesis takes a question about
the unknown, investigates it, and reports the findings and the
meaning of the findings

@ As proof that a candidate is

Technically competent

Able to conduct scholarly research
Has critical-thinking ability
Understand relevant theoretical issues

@ The difference (Masters vs PhD) are the “originality” and
“substantialness” in the context of the research and the thesis

@ Additional criteria for PhD

e An original contribution to knowledge
o The authority underlying the thesis — extensive (breadth) and
intensive (depth) knowledge of their subject



Thesis?

Writing Thesis Requires...

@ Structuring thesis based on best practices (and your SV's)

e Collating and formatting figures. Very time consuming! Use
standard modeling diagrams when appropriate

@ Visualizing how results can be best represented

@ Using appropriate SWs that helps you produce good quality
thesis (IATEX/LyX, MS Word with EndNote)



Thesis?

Generic Thesis Structure

@ Abstract

@ Introduction

@ Literature Review

© Research Methodology
© Proposed Work

© Results and Analysis
O Conclusion
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UTMthesis

UTM Thesis Format

@ The UTM Thesis Manual defines on how theses should be
formatted

@ The latest is 2007 for MS Word users by MS Word users

@ Most researchers (elsewhere but UTM) use IATEX in technical
writing

@ The UTMThesis project
(http://code.google.com/p/utmthesis) was initiated for
seemless thesis typesetting

@ The latest template can be downloaded
http://www.fke.utm.my/postgraduate

o Go tho the download section
o Currently in version 3.13


http://code.google.com/p/utmthesis
http://www.fke.utm.my/postgraduate

UTMthesis

UTM Thesis BTEX Template

@ Auto-generates front pages, table of contents, references, list
of tables/figures, and declarations.

e Easy referencing and figure/table/chapter numbering.

@ Document will be properly formatted according to the UTM
thesis format (well, almost 99%).

@ Reduce the amount of time spent on formatting the thesis, so
you can focus on your work.



UTMthesis

Why BTEX? Why not just MS Word?

e MS Word is only practical tool for (very) simple documents.
o IATEX is a typesetting program - documents are typeset
according a predefined document class and style

o IATEX is not WYSWYG, requires compilation to generate
outputs.



UTMthesis

What is BTEX? LyX?

o TEX: Typesetting language with macro capability. Credit to
Donald Knuth

o IATEX : Macro package built upon TEX. Credit to Leslie
Lamport

@ classes: Descriptions of a type of document, using IATEX.
o styles: Alters the default behavior of IATEX in some way.

e LyX: Visual, WYSIWYM word-processor that uses IATEX to do
its typesetting. Credit to Matthias Ettrich.



Installation

What to Install

Assuming Windows

@ Download ProTEXT: http://www.tug.org/protext/
(>1GB)
o Extract the installer

o Go to miktex > setup > setupxxx.exe and install MikTEX.
Install complete version and use default settings.

@ Download LyX: ftp://ftp.lyx.org/pub/lyx/bin/2.1.0/
LyX-2.1.0-Installer-2.exe. We still have problem with
newer versions

@ Download UTM Thesis LyX template:
http://www.fke.utm.my/postgraduate

e We still have upload problems on
https://utmthesis.googlecode.com


http://www.tug.org/protext/
ftp://ftp.lyx.org/pub/lyx/bin/2.1.0/LyX-2.1.0-Installer-2.exe
ftp://ftp.lyx.org/pub/lyx/bin/2.1.0/LyX-2.1.0-Installer-2.exe
http://www.fke.utm.my/postgraduate
https://utmthesis.googlecode.com

Installation

For Ubuntu Users

From Software Manager
o texlive
@ texlive-common
@ texlive-publishers
o texlive-science
o LyX



Installation

For Mac Users

@ Download Mactex
e LyX



Installation

The Template

@ You just need the following files to start working.

e utmthesis.cls UTM thesis - IATEX class

o utmthesis-authordate.bst - UTM BibTEX style (authordate)
OR utmthesis-numbering.bst - UTM BibTgX style (numbering)

e utmthesis LyX layout

@ Open thesis-template.lyx



Thesis Flow

IATEX-based UTM Thesis Writing Flow

Insert thesis information (author name, degree, faculty, etc)

Include preambles (abstract, abstrak, dedication,
acknowledgement, etc.)

Write mainmatters (main chapters)

Insert the bibliography

Appendices if any



Thesis Flow

Thesis Information

\title{The Thesis Title}

\titletwo{Second Line (Optional)}
\titlethree{Third Line (Optional)}
\author{The Author}

\degree{Master of Engineering (Electrical)}
\faculty{Faculty of Electrical Engineering}
\titledate{October 2013}




Thesis Flow

Thesis Information (cont'd)

\award{4}

1. Bachelor Degree Project Report

2. Master’s Project Report (By course work)

3. Master’s Dissertation (By course work and re-
search)

4. Master’s Thesis (By research)

5. Doctor of Philosophy Thesis

6. Engineering Doctorate Thesis

\superone{M.Y. Supervisor}

\supertwo{M.Y. Other Supervisor}




Thesis Flow

Preambles

Acknowledgement
Dedication
Abstract

Abstrak

o Please check with the Dewan Bahasa website
http://prpm.dbp.gov.my/ for special terminology.

Abbreviations

Symbols


http://prpm.dbp.gov.my/

Thesis Flow

Main Matters: Parts, Chapters, and Sections

The following hierarchy of sectioning is supported.

@ Part (not really required in thesis, unless your thesis is >1000
pages long)
o Chapter

@ Section
@ Subsection
@ Subsubsection

@ Do not go beyond this!



Thesis Flow

Bibliography

Do no do manual citations. Dynamic (and smarter way) — Use
BibTEX

Insert >List/TOC > BibTgX Bibliography

Add database(s) — *.bib (see next slide on how to get one)

Select style (numbering or author-date)
To cite ¥



Thesis Flow

Where to Get BibTEX??

Mendeley (citations manager) - A good online app
Google Scholar
Publishers

(]
*]
(]
@ May require manual edit

@book{b1,

Author = {Leslie Lamport},

Title = {E}X: A Document Preparation System},
Publisher = {Addison-Wesley Professionall,
Year = {1994},

}




Thesis Flow

Appendices

@ After bibliography, Document > Start Appendix Here
@ Must be at the proper place
@ Must be ended with a IATEX command \endmatter

o Else, ToC will have wrong formatting



LyX Environments

Different parts of a document have different purposes; we call
these parts environments.

Environments are a major part of the “What You See Is What
You Mean" philosophy of LyX.

Certain types of documents have special environments

@ An environment may require a certain font style, font size,
indenting, line spacing, and more.

@ The Environment choice box is located on the left end of the

toolbar and looks like this; = *® &



LyX Basic

Spellchecking and Tracking Changes

@ Enable spell-check

e Tools > Preferences >Language Settings > Spell Checker
o Select available spellchecker such as Encant
e Tick Spellcheck continuously

e Document >Change Tracking & Tracking Changes I
o Check changed version on pdf by enabling £



Formatting Texts

Texts are justified by default. You can change the paragraph
alignment with the Edit> Paragraph Settings [¥-.

Fine-Tuning Whitespaces

o Protected Break, Ctrl+Return
o Protected Space, Ctrl4-Space

Forced Page Breaks

o Insert>Formatting> New Page.
o Insert>Formatting> Page Break (stretches page-fill).

Using Different Character Styles

o Noun style (toolbar button 43)
o Emphasized style (toolbar button &)



Lists and Enumerates

o Lists and sublists (can be made nested)

o Enumerate [/
o Itemized [ o
o List (not native to KWTEX) =
e Description E
@ Footnotes can be added through menu Insert> Footnote or
toolbar button [—.

@ Margin notes can be added through menu Insertr>
Marginal Note or the toolbar button | .



LyX Basic

Labels and Cross-References

@ The use of label “Jand cross-reference 5.
@ Dynamic numbering of

o <reference>: prints the float number, this is the default.
(<reference>): prints the float number within two
parentheses, e.g. for Equation.

<page>: prints the page number.

on page <page>: prints the text "on page” and the page
number.

<reference> on page <page>: prints the float number, the
text "on page”, and the page number.



Maths

Typesetting Maths

@ Inline Formula for in-text formula

@ Numbered Formula (single off-the-line formula) or Eqn Array
(multi-line off-the-line formula).

e May type instead of clicking the Math toolbar if you know
basic IATEX command for math.



Maths

Math Mode Features

o Exponents and Subscripts — e.g., x"2y, you will get x% and

type a_1 to get a;.
a

e Fractions — by typing \frac or using the icon Ein the
Math Panel.

@ Roots — using the Math Panel button\"ﬁor the commands
\sqrt or \root.

@ Operators with Limits — \sum for Sum (>_) and \int for
integral (') operators

@ Math Symbols — includes Greek, Operators , Relations,
Arrows. Also AMS additional symbols.

@ Altering Spacing — using protected space.



BXpP
o Functions — button tati for function macros, such as sin, lim,
etc.
@ Accents — circumflex, tilde, breve, etc through command or
Pl

from the Frame decorations symbol set button i..iin the
math panel

@ Brackets and Delimiters — Auto-sizing delimiter via icon [u]

@ Arrays and Multi-line Equations — Matrices are entered using
ooo

ooo
the Math Panel matrix button 999

@ Cases — Insert> Math > Cases Environment or the command
\ cases.



Greek Characters

SO 50 O

op

\alpha
\beta
\gamma
\delta
\epsilon
\varepsilon
\zeta

\eta

\Gamma
\Delta
\Theta

1 g MIT > T D

\theta
\vartheta
\iota
\kappa
\lambda
\mu

\nu

\xi

\Lambda
\Xi
\Pi

N am T g o

e 3M

Maths

o
\pi
\varpi
\rho
\varrho
\sigma
\varsigma

\Sigma
\Upsilon
\Phi

IR S N SR SR |

Q€

\tau
\upsilon
\phi
\varphi
\chi
\psi
\omega

\Psi
\Omega



Math Operators

<
=<
=
<
C
c
C
-
€
l_

\leq

\prec
\preceq

\11

\subset
\subseteq
\sqgsubset”™
\sgsubseteq
\in

\vdash
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\geq

\succ
\succeq

\gg

\supset
\supseteq
\sgsupset”™
\sqsupseteq
\ni

\dashv

2
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Maths

\equiv
\sim
\simeq
\asymp
\approx
\cong
\neq
\doteq
\propto
<

\models
\perp
\mid
\parallel
\bowtie
\Join"*
\smile
\frown

>



Maths

Other Symbols

Must use latexsym, amsfonts or amssymb

+ \pm N \cap ¢ \diamond @  \oplus

F \mp U \cup A \bigtriangleup ©  \ominus

x  \times W  \uplus Vv \bigtriangledown & \otimes

<+ \div M \sqcap <4 \triangleleft ©  \oslash

*  \ast U \sqcup >  \triangleright ®  \odot

*  \star VvV \vee < \lhd" O \bigcirc

o \circ A \wedge >  \rhd" 1 \dagger

e \bullet \ \setminus < \unlhd® i \ddagger
\cdot 2 \wr > \unrhd”* II  \amalg

+ o+



3 \hat{a} 4 \acute{a} 3 \bar{a} a \dot{a}
3 \breve{a} 3 \check{a} a \grave{a} 3 \vec{al}
3 \ddot{a} & \tilde{a}

abc  \widetilde{abc} abc  \widehat{abc}

SBE \overleftarrow{abc} 553 \overrightarrow{abc}
abc  \overline{abc} abc  \underline{abc}

abc \overbrace{abc} abc \underbrace{abc}



Maths

Theorems

@ LyX has no standard way of inserting theorem, definition, etc.
@ Can use native IATEX way for inserting Theorem environment

@ Declare \newtheorem{thm}{Theorem Name} in the IATEX
preamble

@ Then call the thm environment

\begin{thm} [Euclid]
The theorem
\end{thm}




Floats

What are Floats

A float doesn't have a fixed location.

It can “float” forward or backward to wherever it fits best to
get a high quality layout.

Caption as part of a float.
To insert, use the menu Insert> Floats.

o Figure Floats — Insert> Float > Figure ..
o Table Floats — Insert > Float > Table. =
o Algorithm Floats — Insert > Float> Algorithm.

Can create subfigure with double Insert > Float > Figure and
again, insert> Float> Figure

o This inserts a "subfigure float” into the float)



Floats

Float Placement

Right-clicking on a float-box opens a dialog where you can alter
the placement options

Here if possible: try to place the float at the position where it is
inserted

Top of page: try to place the float at the top of the current page

Bottom of page: try to place the float at the bottom of the
current page

Page of floats: try to place the float at an own page

If you use the default placement, IATEX will first try out
Here if possible, then Top of page, and then the others.



Floats

Graphics and Images

@ Place the cursor and click on the toolbar icon Bor select
Insert > Graphics from the menu.

@ Then a dialog will appear to choose the file to load.

@ You may also copy and paste as well (just like MS Word) —
png image

@ The image settings can be adjusted

@ Supported types

e Bitmap images GIF, PNG, JPG. Try to avoid if possible.
e Scalable images SVG, EPS, PDF.



Floats

Tables

@ Insert a table using either the toolbar button =or the menu
Insert> Table

@ The default table has lines around all cells and the first row
appears separated from the rest of the table (double line)

@ You can adjust the settings of the cell and row/column
respectively.

@ Longtables are also supported.



Floats

Algorithms

@ Method 1

e insert>float>algorithm
e Set caption
o Edit> paste external selection > as lines (cntrl+shift+v)

@ Method 2

o Use algorithmic environments (made obsolete by algorithm?2e).
o Require ERT



Floats

Algorithmic Package

@ Require Algorithm and Algorithmic packages
@ Obsolete (replaced by algorithm?2e)

Algorithm 1 Calculate y = 2"
Require: n >0
Ensure: y = 2"
y<=1
X<x
N <n
while N # 0 do
if N is even then
X<XxX
N <= N/2
else { N is odd}
y=yx X
N<N-1
end if
end while




Floats

Need Evil Red Text (ERT)

@ Refers to insertion of IATEX command ®or ctrl+L

\begin{algorithmic}

\REQUIRE $n \geq 0%

\ENSURE $y = x"n$

\STATE $y \Leftarrow 1%

\STATE $X \Leftarrow x$

\STATE $N \Leftarrow n$
\WHILE{$N \neq 0$}

\IF{$N$ is even}

\STATE $X \Leftarrow X \times X$
\STATE $N \Leftarrow N / 2§ \ELSE [$N$ is odd]
\STATE $y \Leftarrow y \times X$
\STATE $N \Leftarrow N - 1$
\ENDIF

\ENDWHILE

\end{algorithmic}




Ext. Docs.

File Listings

@ Insert>File> plain text to insert ext in verbatim mode.
@ Insert >File > Child document

e Options for include, input, verbatim, program listing.
e Verbatim in typewriter font
e Program listing can be configured language-aware



Ext. Docs.

Language-Aware Program Listings

@ You may change the type to program listing and configure it
as you need

breaklines=true

captionpos=b

frame=tb

language=Python
commentstyle={\normalfont\textit}
keywordstyle={\textbf}

o Refer to Listings IATEX package.



Ext. Docs.

Inserting Pdfs

@ Insert >File > External Materials
o Select pdf

o Use pages option to specify pages to include.



Best Practices

Thesis Writing Best Practices

Turn-on spelling check

Enable track changes between thesis versions
Dynamic bibliography using BibTEX

Always use cross-referencing

Dynamic width for figures/tables

Scalable graphics when available
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